# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^,\n]+(?:,|$)){2}([^,\n]+(?:,|$))*|^.*$/$1/gm;t' <<< "2.99
1.55763239875389,2.80373831775701,1.24610591900312
1.55763239875389,2.80373831775701,1.24610591900312,4.04984423676012,26.4797507788162,2.49221183800623,299"