re = /^([^,\n]+(?:,|$)){2}([^,\n]+(?:,|$))*|^.*$/m
str = '2.99
1.55763239875389,2.80373831775701,1.24610591900312
1.55763239875389,2.80373831775701,1.24610591900312,4.04984423676012,26.4797507788162,2.49221183800623,299'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result