const regex = new RegExp('^([^,\\n]+(?:,|$)){2}([^,\\n]+(?:,|$))*|^.*$', 'gm')
const str = `2.99
1.55763239875389,2.80373831775701,1.24610591900312
1.55763239875389,2.80373831775701,1.24610591900312,4.04984423676012,26.4797507788162,2.49221183800623,299`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);