#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^,\n]+(?:,|$)){2}([^,\n]+(?:,|$))*|^.*$"
Local $sString = "2.99" & @CRLF & _
"1.55763239875389,2.80373831775701,1.24610591900312" & @CRLF & _
"1.55763239875389,2.80373831775701,1.24610591900312,4.04984423676012,26.4797507788162,2.49221183800623,299"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)