#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^/services/?(?:page/[0-9]+)?/?$"
Local $sString = "/services" & @CRLF & _
"/services/" & @CRLF & _
"/services/page/2" & @CRLF & _
"/services/page/140/" & @CRLF & _
"/service/page" & @CRLF & _
"/servicesx/page" & @CRLF & _
"/services/page" & @CRLF & _
"/services/page/" & @CRLF & _
"/services/pages" & @CRLF & _
"/services/pages/2/" & @CRLF & _
"/services/foo" & @CRLF & _
"/services/foo/page" & @CRLF & _
"/xyz/services/page/2" & @CRLF & _
"/services/page/4/foo"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)