const regex = new RegExp('^/services/?(?:page/[0-9]+)?/?$', 'gm')
const str = `/services
/services/
/services/page/2
/services/page/140/
/service/page
/servicesx/page
/services/page
/services/page/
/services/pages
/services/pages/2/
/services/foo
/services/foo/page
/xyz/services/page/2
/services/page/4/foo`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);