$re = '~^/services/?(?:page/[0-9]+)?/?$~m';
$str = '/services
/services/
/services/page/2
/services/page/140/
/service/page
/servicesx/page
/services/page
/services/page/
/services/pages
/services/pages/2/
/services/foo
/services/foo/page
/xyz/services/page/2
/services/page/4/foo';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;