import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\d{1,2}-)?\\d{1,2})(?:st|nd|rd|th)?[ ./-](feb|\\d{1,2})(?:[ ./-](\\d{2,4}))?|(feb|\\d{1,2})[ ./-]((?:\\d{1,2}-)?\\d{1,2})(?:st|nd|rd|th)?(?:[ ./-](\\d{2,4}))?";
final String string = "3 feb 2020 10:30\n\n"
+ "03 feb 2020\n\n"
+ "02-03-2020\n\n"
+ "11-13-02-2021\n\n"
+ "11-12 feb-2020\n\n"
+ "3 feb 20\n\n"
+ "20-22 feb 2020\n\n"
+ "10:00pm 3 feb 2020\n\n"
+ "2 feb\n\n"
+ "feb 2\n\n"
+ "20 feb\n\n"
+ "feb 2nd\n\n"
+ "2nd feb\n\n"
+ "30th feb\n\n"
+ "feb 30th\n\n"
+ "30 feb 2020\n\n"
+ "30/02/2020\n\n"
+ "02/30/2020\n\n"
+ "alda a\n\n"
+ "The quick brown fox jumped over 2 dogs on the feb 20th 2020\n\n"
+ "3\n\n"
+ "30";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}