use strict;
my $str = '3 feb 2020 10:30
03 feb 2020
02-03-2020
11-13-02-2021
11-12 feb-2020
3 feb 20
20-22 feb 2020
10:00pm 3 feb 2020
2 feb
feb 2
20 feb
feb 2nd
2nd feb
30th feb
feb 30th
30 feb 2020
30/02/2020
02/30/2020
alda a
The quick brown fox jumped over 2 dogs on the feb 20th 2020
3
30';
my $regex = qr/((?:\d{1,2}-)?\d{1,2})(?:st|nd|rd|th)?[ ./-](feb|\d{1,2})(?:[ ./-](\d{2,4}))?|(feb|\d{1,2})[ ./-]((?:\d{1,2}-)?\d{1,2})(?:st|nd|rd|th)?(?:[ ./-](\d{2,4}))?/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}