import Foundation
let pattern = #"((?:\d{1,2}-)?\d{1,2})(?:st|nd|rd|th)?[ ./-](feb|\d{1,2})(?:[ ./-](\d{2,4}))?|(feb|\d{1,2})[ ./-]((?:\d{1,2}-)?\d{1,2})(?:st|nd|rd|th)?(?:[ ./-](\d{2,4}))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
3 feb 2020 10:30
03 feb 2020
02-03-2020
11-13-02-2021
11-12 feb-2020
3 feb 20
20-22 feb 2020
10:00pm 3 feb 2020
2 feb
feb 2
20 feb
feb 2nd
2nd feb
30th feb
feb 30th
30 feb 2020
30/02/2020
02/30/2020
alda a
The quick brown fox jumped over 2 dogs on the feb 20th 2020
3
30
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)