// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)((?:\d{1,2}-)?\d{1,2})(?:st|nd|rd|th)?[ ./-](feb|\d{1,2})(?:[ ./-](\d{2,4}))?|(feb|\d{1,2})[ ./-]((?:\d{1,2}-)?\d{1,2})(?:st|nd|rd|th)?(?:[ ./-](\d{2,4}))?").unwrap();
let string = "3 feb 2020 10:30
03 feb 2020
02-03-2020
11-13-02-2021
11-12 feb-2020
3 feb 20
20-22 feb 2020
10:00pm 3 feb 2020
2 feb
feb 2
20 feb
feb 2nd
2nd feb
30th feb
feb 30th
30 feb 2020
30/02/2020
02/30/2020
alda a
The quick brown fox jumped over 2 dogs on the feb 20th 2020
3
30";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}