# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:\d{1,2}-)?\d{1,2})(?:st|nd|rd|th)?[ ./-](feb|\d{1,2})(?:[ ./-](\d{2,4}))?|(feb|\d{1,2})[ ./-]((?:\d{1,2}-)?\d{1,2})(?:st|nd|rd|th)?(?:[ ./-](\d{2,4}))?"
test_str = ("3 feb 2020 10:30\n\n"
"03 feb 2020\n\n"
"02-03-2020\n\n"
"11-13-02-2021\n\n"
"11-12 feb-2020\n\n"
"3 feb 20\n\n"
"20-22 feb 2020\n\n"
"10:00pm 3 feb 2020\n\n"
"2 feb\n\n"
"feb 2\n\n"
"20 feb\n\n"
"feb 2nd\n\n"
"2nd feb\n\n"
"30th feb\n\n"
"feb 30th\n\n"
"30 feb 2020\n\n"
"30/02/2020\n\n"
"02/30/2020\n\n"
"alda a\n\n"
"The quick brown fox jumped over 2 dogs on the feb 20th 2020\n\n"
"3\n\n"
"30")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.