using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\&)(?!.*<).*?(?=[A-Z])";
string input = @"<td>ARMOIRE 6 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td><td>Longueur : 297 cm - Profondeur : 73 cm - Hauteur : 260 cm.</span><br></td></tr><tr><td><b><u>ARMOIRE
4 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td></tr><tr><td>Chevet
<td>ARMOIRE 6 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td><td>Longueur : 297 cm - Profondeur : 73 cm - Hauteur : 260 cm.</span><br></td></tr><tr><td><b><u>ARMOIRE 4 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td></tr><tr><td>Chevet";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}