$re = '/(?<=\&)(?!.*<).*?(?=[A-Z])/m';
$str = '<td>ARMOIRE 6 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td><td>Longueur : 297 cm - Profondeur : 73 cm - Hauteur : 260 cm.</span><br></td></tr><tr><td><b><u>ARMOIRE
4 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td></tr><tr><td>Chevet
<td>ARMOIRE 6 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td><td>Longueur : 297 cm - Profondeur : 73 cm - Hauteur : 260 cm.</span><br></td></tr><tr><td><b><u>ARMOIRE 4 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td></tr><tr><td>Chevet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);