package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z-_][^A-Z\s]{1,21}$`)
var str = `lkjlksjdfdsqf
lkjljl-----kjlkj-
klhlkhsdf---fdqsd__T
klhlkhsdfsdf---fdqs dfqds_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}