const regex = /^[a-z-_][^A-Z\s]{1,21}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z-_][^A-Z\\s]{1,21}$', 'gm')
const str = `lkjlksjdfdsqf
lkjljl-----kjlkj-
klhlkhsdf---fdqsd__T
klhlkhsdfsdf---fdqs dfqds_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}