use strict;
my $str = 'lkjlksjdfdsqf
lkjljl-----kjlkj-
klhlkhsdf---fdqsd__T
klhlkhsdfsdf---fdqs dfqds_';
my $regex = qr/^[a-z-_][^A-Z\s]{1,21}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}