import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "translate\\s*\\((?|'((?:[^']*?(?:\\\\')[^']*?)*)'|\"((?:[^\"]*?(?:\\\\\"|)[^\"]*?)*)\")(?:|[, ]*(?:'|\")(.*?)(?:\"|'))\\)";
final String string = "translate('hello what\\'s wrong');\n"
+ "translate('hello what\\'s wrong');\n"
+ "translate('hello what\\'s wrong');\n"
+ "translate(\"hello what's w: )rong\");\n"
+ "translate(\"hello whats wrong\");\n"
+ "translate('hello what\\'s wrong');\n\n"
+ "translate('hello what\\'s wrong', 'namespace');\n"
+ "translate('hell\\'o what\\'s wro\\'ng', 'namespace');\n"
+ "translate(\"hello what\\\"s \\\" s\\\" wrong\", 'namespace');\n"
+ "translate('hell(o) (wh)at\\'s wrong', \"namespace\");\n"
+ "translate(\"hello what's wrong\", \"namespace\");\n\n"
+ "translate ('hello what\\'s wrong');\n"
+ "translate(\"hel\n"
+ "lo what's wrong\");\n\n"
+ "translate('hello what\\'s wrong', 'namespace');\n"
+ "translate(\"hello wh\n"
+ "at's wrong\", 'namespace');\n"
+ "translate('hello what\\'s wrong', \"namespace\");\n"
+ "translate(\"hello what's wrong\", \"namespace\");";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}