// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?usi)translate\s*\((?|'((?:[^']*?(?:\\')[^']*?)*)'|"((?:[^"]*?(?:\\"|)[^"]*?)*)")(?:|[, ]*(?:'|")(.*?)(?:"|'))\)"#).unwrap();
let string = "translate('hello what\\'s wrong');
translate('hello what\\'s wrong');
translate('hello what\\'s wrong');
translate(\"hello what's w: )rong\");
translate(\"hello whats wrong\");
translate('hello what\\'s wrong');
translate('hello what\\'s wrong', 'namespace');
translate('hell\\'o what\\'s wro\\'ng', 'namespace');
translate(\"hello what\\\"s \\\" s\\\" wrong\", 'namespace');
translate('hell(o) (wh)at\\'s wrong', \"namespace\");
translate(\"hello what's wrong\", \"namespace\");
translate ('hello what\\'s wrong');
translate(\"hel
lo what's wrong\");
translate('hello what\\'s wrong', 'namespace');
translate(\"hello wh
at's wrong\", 'namespace');
translate('hello what\\'s wrong', \"namespace\");
translate(\"hello what's wrong\", \"namespace\");";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}