# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"translate\s*\((?|'((?:[^']*?(?:\\')[^']*?)*)'|\"((?:[^\"]*?(?:\\\"|)[^\"]*?)*)\")(?:|[, ]*(?:'|\")(.*?)(?:\"|'))\)"
test_str = ("translate('hello what\\'s wrong');\n"
"translate('hello what\\'s wrong');\n"
"translate('hello what\\'s wrong');\n"
"translate(\"hello what's w: )rong\");\n"
"translate(\"hello whats wrong\");\n"
"translate('hello what\\'s wrong');\n\n"
"translate('hello what\\'s wrong', 'namespace');\n"
"translate('hell\\'o what\\'s wro\\'ng', 'namespace');\n"
"translate(\"hello what\\\"s \\\" s\\\" wrong\", 'namespace');\n"
"translate('hell(o) (wh)at\\'s wrong', \"namespace\");\n"
"translate(\"hello what's wrong\", \"namespace\");\n\n"
"translate ('hello what\\'s wrong');\n"
"translate(\"hel\n"
"lo what's wrong\");\n\n"
"translate('hello what\\'s wrong', 'namespace');\n"
"translate(\"hello wh\n"
"at's wrong\", 'namespace');\n"
"translate('hello what\\'s wrong', \"namespace\");\n"
"translate(\"hello what's wrong\", \"namespace\");")
matches = re.finditer(regex, test_str, re.UNICODE | re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.