use strict;
my $str = 'translate(\'hello what\\\'s wrong\');
translate(\'hello what\\\'s wrong\');
translate(\'hello what\\\'s wrong\');
translate("hello what\'s w: )rong");
translate("hello whats wrong");
translate(\'hello what\\\'s wrong\');
translate(\'hello what\\\'s wrong\', \'namespace\');
translate(\'hell\\\'o what\\\'s wro\\\'ng\', \'namespace\');
translate("hello what\\"s \\" s\\" wrong", \'namespace\');
translate(\'hell(o) (wh)at\\\'s wrong\', "namespace");
translate("hello what\'s wrong", "namespace");
translate (\'hello what\\\'s wrong\');
translate("hel
lo what\'s wrong");
translate(\'hello what\\\'s wrong\', \'namespace\');
translate("hello wh
at\'s wrong", \'namespace\');
translate(\'hello what\\\'s wrong\', "namespace");
translate("hello what\'s wrong", "namespace");';
my $regex = qr/translate\s*\((?|'((?:[^']*?(?:\\')[^']*?)*)'|"((?:[^"]*?(?:\\"|)[^"]*?)*)")(?:|[, ]*(?:'|")(.*?)(?:"|'))\)/usip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}