$re = '/translate\s*\((?|\'((?:[^\']*?(?:\\\\\')[^\']*?)*)\'|"((?:[^"]*?(?:\\\\"|)[^"]*?)*)")(?:|[, ]*(?:\'|")(.*?)(?:"|\'))\)/usi';
$str = 'translate(\'hello what\\\'s wrong\');
translate(\'hello what\\\'s wrong\');
translate(\'hello what\\\'s wrong\');
translate("hello what\'s w: )rong");
translate("hello whats wrong");
translate(\'hello what\\\'s wrong\');
translate(\'hello what\\\'s wrong\', \'namespace\');
translate(\'hell\\\'o what\\\'s wro\\\'ng\', \'namespace\');
translate("hello what\\"s \\" s\\" wrong", \'namespace\');
translate(\'hell(o) (wh)at\\\'s wrong\', "namespace");
translate("hello what\'s wrong", "namespace");
translate (\'hello what\\\'s wrong\');
translate("hel
lo what\'s wrong");
translate(\'hello what\\\'s wrong\', \'namespace\');
translate("hello wh
at\'s wrong", \'namespace\');
translate(\'hello what\\\'s wrong\', "namespace");
translate("hello what\'s wrong", "namespace");';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);