using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[$#]+(?=[A-Za-z])";
string substitution = @"";
string input = @"This$#is
This$#";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}