import re
regex = re.compile(r"[$#]+(?=[A-Za-z])", flags=re.MULTILINE)
test_str = ("This$#is\n"
"This$#")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)