use strict;
my $str = 'This$#is
This$#';
my $regex = qr/[$#]+(?=[A-Za-z])/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";