$re = '/[$#]+(?=[A-Za-z])/m';
$str = 'This$#is
This$#';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;