#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=asad=).*?(?=(?:&|\n))"
Local $sString = "https://teststore.com/products/mens-sandals-black?asad=253485_e1c6ae3ad&ol_color=13968" & @CRLF & _
"https://teststore.com/products/womens-sandals-tan-?asad=252485_c1c63c01d&variant=2770725251" & @CRLF & _
"https://teststore.com/products/mens-shoes-blue?asad=254325_c1c63c01d" & @CRLF & _
"https://teststore.com/collections/men/products/mens-sneakers?variant=310637539&asad=204207_e1c1756d5" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")