# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=asad=).*?(?=(?:&|\n))"
test_str = ("https://teststore.com/products/mens-sandals-black?asad=253485_e1c6ae3ad&ol_color=13968\n"
"https://teststore.com/products/womens-sandals-tan-?asad=252485_c1c63c01d&variant=2770725251\n"
"https://teststore.com/products/mens-shoes-blue?asad=254325_c1c63c01d\n"
"https://teststore.com/collections/men/products/mens-sneakers?variant=310637539&asad=204207_e1c1756d5\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.