use strict;
my $str = 'https://teststore.com/products/mens-sandals-black?asad=253485_e1c6ae3ad&ol_color=13968
https://teststore.com/products/womens-sandals-tan-?asad=252485_c1c63c01d&variant=2770725251
https://teststore.com/products/mens-shoes-blue?asad=254325_c1c63c01d
https://teststore.com/collections/men/products/mens-sneakers?variant=310637539&asad=204207_e1c1756d5
';
my $regex = qr/(?<=asad=).*?(?=(?:&|\n))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}