import Foundation
let pattern = #"(?<=asad=).*?(?=(?:&|\n))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://teststore.com/products/mens-sandals-black?asad=253485_e1c6ae3ad&ol_color=13968
https://teststore.com/products/womens-sandals-tan-?asad=252485_c1c63c01d&variant=2770725251
https://teststore.com/products/mens-shoes-blue?asad=254325_c1c63c01d
https://teststore.com/collections/men/products/mens-sneakers?variant=310637539&asad=204207_e1c1756d5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)