$re = '/(?<=asad=).*?(?=(?:&|\n))/';
$str = 'https://teststore.com/products/mens-sandals-black?asad=253485_e1c6ae3ad&ol_color=13968
https://teststore.com/products/womens-sandals-tan-?asad=252485_c1c63c01d&variant=2770725251
https://teststore.com/products/mens-shoes-blue?asad=254325_c1c63c01d
https://teststore.com/collections/men/products/mens-sneakers?variant=310637539&asad=204207_e1c1756d5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);