using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"mxtiming_(?<ppp>\d*_[^_]*_\d*)\.log";
string input = @"mxtiming_commoditynearbyonindexhistoricaldata_20170306-093752167_1294331273_6902.log
mxtiming_730010_dell427srv_121.log";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}