re = /mxtiming_(?<ppp>\d*_[^_]*_\d*)\.log/
str = 'mxtiming_commoditynearbyonindexhistoricaldata_20170306-093752167_1294331273_6902.log
mxtiming_730010_dell427srv_121.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end