$re = '/mxtiming_(?<ppp>\d*_[^_]*_\d*)\.log/';
$str = 'mxtiming_commoditynearbyonindexhistoricaldata_20170306-093752167_1294331273_6902.log
mxtiming_730010_dell427srv_121.log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);