import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "mxtiming_(?<ppp>\\d*_[^_]*_\\d*)\\.log";
final String string = "mxtiming_commoditynearbyonindexhistoricaldata_20170306-093752167_1294331273_6902.log\n"
+ "mxtiming_730010_dell427srv_121.log";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}