package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`mxtiming_(?<ppp>\d*_[^_]*_\d*)\.log`)
var str = `mxtiming_commoditynearbyonindexhistoricaldata_20170306-093752167_1294331273_6902.log
mxtiming_730010_dell427srv_121.log`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}