# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:.*?\K//){3}"
test_str = ("ABC//DEG//IJK//LMN//OPQ//rstuvwxyz\n"
"BCA//EGD//JKI//MNL//PQO//stuvwxyzr\n"
"ACB//DGE//IJK//LNM//OQP//rstuvwxyz\n"
"ABC//DEG//IJK//LMN//OPQ//rstuvwxyz\n"
"CAB//GDE//KIJ//NLM//QOP//rstuvwxyz\n"
"BAC//EDG//JIK//MLN//POQ//rstuvwxyz")
subst = "\\\\\\\\"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.