using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9].{2,3}$";
string input = @"a
abc
abcd
abcde
a1
a12
a123
a1234
aa1
aa12
aa123
aa1234
a1
a1a
a1a1
a1a1a
a-
a-1
a-1a
a-1-
a-1a-
0012";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}