// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9].{2,3}$").unwrap();
let string = "a
abc
abcd
abcde
a1
a12
a123
a1234
aa1
aa12
aa123
aa1234
a1
a1a
a1a1
a1a1a
a-
a-1
a-1a
a-1-
a-1a-
0012";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}