# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z0-9].{2,3}$"
test_str = ("a\n"
"abc\n"
"abcd\n"
"abcde\n"
"a1\n"
"a12\n"
"a123\n"
"a1234\n"
"aa1\n"
"aa12\n"
"aa123\n"
"aa1234\n"
"a1\n"
"a1a\n"
"a1a1\n"
"a1a1a\n"
"a-\n"
"a-1\n"
"a-1a\n"
"a-1-\n"
"a-1a-\n"
"0012")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.