use strict;
my $str = 'a
abc
abcd
abcde
a1
a12
a123
a1234
aa1
aa12
aa123
aa1234
a1
a1a
a1a1
a1a1a
a-
a-1
a-1a
a-1-
a-1a-
0012';
my $regex = qr/^[a-zA-Z0-9].{2,3}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}