using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\.\d+";
string input = @"TOKEN (SwapToken) - 1005.00000127 TOKEN
10.2
12421421412.4214124214
24213.2123321
3432.423";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}