import Foundation
let pattern = #"\d+\.\d+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
TOKEN (SwapToken) - 1005.00000127 TOKEN
10.2
12421421412.4214124214
24213.2123321
3432.423
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)