$re = '/\d+\.\d+/';
$str = 'TOKEN (SwapToken) - 1005.00000127 TOKEN
10.2
12421421412.4214124214
24213.2123321
3432.423';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);