#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([А-Я]{1}[а-яё]{1,23}|[A-Z]{1}[a-z]{1,23})$"
Local $sString = "Иван" & @CRLF & _
"Иноkentiy" & @CRLF & _
"А" & @CRLF & _
"КоСтЯ" & @CRLF & _
"Frenk" & @CRLF & _
"владимир" & @CRLF & _
"bob"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")