re = /^([А-Я]{1}[а-яё]{1,23}|[A-Z]{1}[a-z]{1,23})$/m
str = 'Иван
Иноkentiy
А
КоСтЯ
Frenk
владимир
bob'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end