$re = '@^([А-Я]{1}[а-яё]{1,23}|[A-Z]{1}[a-z]{1,23})$@m';
$str = 'Иван
Иноkentiy
А
КоСтЯ
Frenk
владимир
bob';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);