const regex = new RegExp('^([А-Я]{1}[а-яё]{1,23}|[A-Z]{1}[a-z]{1,23})$', 'gm')
const str = `Иван
Иноkentiy
А
КоСтЯ
Frenk
владимир
bob`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}