package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([А-Я]{1}[а-яё]{1,23}|[A-Z]{1}[a-z]{1,23})$`)
var str = `Иван
Иноkentiy
А
КоСтЯ
Frenk
владимир
bob`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}