using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+(?= |$)";
string substitution = @"'$0',";
string input = @"32132132132 32132132132 321321321323 32132132132132";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}